Skip to content ↓ | Skip to navigation ↓

What has happened?
A severe zero-day vulnerability has been fixed in WordPress, which – if left unpatched – could allow a malicious attacker to modify the content of any post or page on a WordPress site.

Woah! Any post or page could be hijacked?
Yes, it’s as though you’ve handed the reins of your site over to a malicious hacker and said – “publish what you like, it’s yours.”

So they could deface my company’s website or blog?
Worse than that. They could publish malicious links designed to infect unsuspecting computer users, or attempt to phish credentials such as passwords from visitors who would be unware that your website was under criminal control.

So I guess a security patch has just been released?
That’s where things get interesting. Yes, version 4.7.2 of WordPress addresses the security vulnerability, but it was released a week ago (26 January 2017).

How come you’re warning us about the vulnerability now?
WordPress 4.7.2 fixed the issue, but it was a “silent patch”. The fix was hidden within other issues in order to give everyone time to patch their systems.

At the time of 4.7.2’s release details of the flaw were kept secret, as the security community raced to ensure that as many sites were protected as possible as Aaron Campbell explained in a WordPress blog post:

“We believe transparency is in the public’s best interest. It is our stance that security issues should always be disclosed. In this case, we intentionally delayed disclosing this issue by one week to ensure the safety of millions of additional WordPress sites.”

Details of the severe vulnerability and the silent patch have only been made public now.

When did WordPress find out about the vulnerability?
Researchers at Sucuri discovered the vulnerability, and responsibly disclosed them to WordPress on 20 January 2017.

Shouldn’t we have been told about the vulnerability then if it was that serious?
At that time a patch wasn’t available. If details had been shared at that point there is a danger that malicious hackers might have had a field day attacking millions of blogs and company websites.

Major WordPress-hosting services and web security firms offering Web Application Firewalls (WAFs) such as Cloudflare and Incapsula were warned about the vulnerability ahead of this week’s public disclosure, and ahead of the release of WordPress 4.7.2 last week, in order to mitigate attacks and determine whether attempts were being made to exploit the security hole in the wild.

Fortunately, no evidence was found of the flaw being exploited:

“Data from all four WAFs and WordPress hosts showed no indication that the vulnerability had been exploited in the wild. As a result, we made the decision to delay disclosure of this particular issue to give time for automatic updates to run and ensure as many users as possible were protected before the issue was made public.”

I run a self-hosted WordPress site. Is it at risk?
If you’re running a version of WordPress earlier than version 4.7.2 then you should update as soon as possible. The security issue is no longer a secret. You might want to consider enabling automatic updates on your WordPress installation.

Self-hosted? What does that mean?
Sites running self-hosted versions of WordPress from WordPress.org are different from the many millions of blogs which run on WordPress.com. WordPress.com, run by Automattic, manages the installation of WordPress for you, and looks after security on your behalf.

Although there are some limitations on what website owners can do on WordPress.com, they can always be sure that they are running the latest version of WordPress.

Don’t worry if you find the names confusing. Everyone finds the names confusing. It’s kinda crazy.

Where can I find out more technical details of the flaw?
Check out this blog post by Sucuri researcher Marc-Alexandre Montpas.

 

Editor’s Note: The opinions expressed in this guest author article are solely those of the contributor, and do not necessarily reflect those of Tripwire, Inc.

Save

SANS White Paper: Security Basics
  • karl

    Excellent. I have updated my WP installation to 4.7.2

  • BraveInsane

    I think this bug only relates to WordPress sites running version 4.7 (or 4.7.1).

    The bug relates to functionality released in version 4.7 of the WordPress core (REST API functionality).

    Previous versions did not have this REST API functionality and so I believe do not have the bug.